TLS 1.1 ir TLS 1.2 palaikymas "Outlook" programai, kai OS "Windows7"“

Iš LITNET WIKI.
14:41, 13 liepos 2018 versija, sukurta JTadmin (Aptarimas | indėlis)
(skirt) ← Ankstesnė versija | Dabartinė versija (skirt) | Vėlesnė versija→ (skirt)
Peršokti į: navigacija, paiešką

Kadangi TLS 1.0 protokolas nėra saugus, jis išjungtas visame pasaulyje, tačiau programos, naudojančios WinHTTP Windows7 ​​įrenginiuose, palaiko tik TLS 1.0. Todėl "Outlook" išmeta klaidą "your server does not support the connection encryption type you have specified”.
Yra du būdai tai išspręsti:

 HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\WinHttp
 HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Internet Settings\WinHttp

Jei Jūsų Windows 7 buvo atnaujinti, galite pasinaudoti instrukcija https://support.cybersource.com/s/article/How-do-I-enable-TLS-1-2-on-Windows-7. Užtenka atsisiųsti TLS 1.x on Window 7.zip ir įvykdyti failą Enable TLS 1.x on Windows 7.reg.